TKActions V6 and Photoshop CC 2019

I’ve been testing the TKActions V6 panel with the newly released Photoshop CC 2019 on both Mac and Windows computers and everything seems to be working properly. There aren’t any major issues associated with the panel as far as I can tell. However, with every new version of Photoshop some users experience problems and there are almost always new bugs in Photoshop itself. These issues are usually NOT due to the V6 panel, though they can affect its performance. I’ll review a couple of situations below that have been brought to my attention.

Lightroom-to-Photoshop issue (Windows-only)

As some of you might be aware, Photoshop CC 2019 has a major bug. When you open Photoshop by opening an image directly from Lightroom, many functions are grayed-out on the Photoshop menus. This problem appears to be a Windows-only bug. This Photoshop thread discusses it and has an official Adobe recommended workaround. Basically, Windows users need to open Photoshop CC BEFORE opening images from Lightroom. Doing this makes all the functions in the Photoshop menus appropriately available. The V6 panel runs some of these standard Photoshop functions as part of the steps programmed into the panel’s actions. So launching Photoshop CC first insures that these functions are available and can be accessed by the panel.

UPDATE: I have been informed that this problem can also occur when opening an image from Bridge or ACR. So, again, if you’re on Windows and have this problem, it’s important to make sure Photoshop CC is open BEFORE opening images from Lightroom, Bridge, or Adobe Camera Raw. As I mention in the comments below, here’s a test to see if your panel is working properly:

  1. Reboot your computer.
  2. Open Photoshop CC directly from its launch icon on your computer. Do NOT open PS CC by opening an image from Lightroom, Bridge, or ACR. Have Photoshop CC open BEFORE opening any image.
  3. Now open an image (by whichever method you prefer).
  4. Try using the panel.

The panel should now work normally and will demonstrate that this an Adobe bug and not an issue with the panel itself.

Modules missing from workspace

When you install a new version of Photoshop CC, the workspace preferences from the old version usually transfer to the new version including the V6 modules you had open and their placement in your workspace. Unfortunately, sometimes this does not happen and it will look like the V6 modules disappeared and need to be reinstalled. However, re-installation is seldom necessary. Instead, first click the Workspace menu in the upper right corner of Photoshop (red box below) and see if your last workspace is listed there. If it is, click it and it might restore your last workspace including the V6 modules.

workspace menu button

If that doesn’t work, go to the Window > Extensions menu in Photoshop and click each of the modules you want to open.

Windows - Extensions menu

You might need to reconfigure the modules into your preferred arrangement using the information in Sean Bagshaw’s video.

If there are no modules listed under Windows > Extensions, you can check your installation by looking for the installation folders in the “extensions” folder in the following path:

MAC:  Macintosh HD > Library > Application Support > Adobe > CEP > extensions

Windows:  Computer > C: > Program Files (x86) > Common Files > Adobe > CEP > extensions

This installation path has worked since Photoshop CC 2014 and is correct for Photoshop CC 2019 also. If your V6 modules were installed correctly in CC 2018, then it’s quite likely they’re properly installed in CC 2019 as well, but it’s always a good idea to check. The installation folders have the following names:

com.tk.batchvsix
com.tk.combovsix
com.tk.cxvsix
com.tk.rmtwovsix

If you don’t see these folders in the “extensions” folder, double-check that you have the correct installation path to the “extensions” folder. It’s unusual that the folders would be removed simply by installing the new version of Photoshop CC. If you’re sure the installation folders are missing, contact me and I’ll reactivate your download link.

If you see the installation folders in your “extensions” folder, then your V6 panel is properly installed and will show up in the Window > Extension menu of Photoshop CC if your application is working properly. If you don’t see the modules listed in the Windows > Extensions menu, reboot your computer and check again. That’s always something worth doing when things aren’t working properly.

Another thing to check if the modules don’t show up under Window > Extensions in Photoshop is the preferences. Go to the Preferences > Plug-ins menu and make sure that “Load Extensions Panels” checkbox is checked. This has been a problem for a couple of people. The checkbox needs to be checked in order for panels like TKActions V6 to show up in the Window > Extensions menu.

load extension panels preferences

Corrupted preferences

While the two problems listed above have occurred for a few users, there are also occasionally really weird problems that only happen for one user and can’t be replicated. This is often a sign of corrupted Photoshop preferences files and the only solution is to reset them. This Adobe video shows how to do that. But feel free to check with me first to make sure that I’ve not seen the problem before and have a different recommendation.

In a few cases where the above solutions don’t work, uninstalling and reinstalling PS CC is necessary, but that’s rare. Always try rebooting the computer before reinstalling Photoshop as some odd problems can occasionally be solved with a reboot.

Please contact me if you notice other problems with the V6 panel and Photoshop CC 2019. My sense is that CC 2019 is quite buggy yet, so there may be other issues yet to be discovered. If I can replicate the problem, I’m usually able to fix it or recommend a workaround.

If I hear of other problems with Photoshop that are regularly affecting the panel, I’ll post additional information on this blog. At this time, though, the V6 panel works fine in Photoshop CC 2019 and is available to make luminosity masks when you need them.

18 thoughts on “TKActions V6 and Photoshop CC 2019

  1. Thanks for the update. The only issue I’ve observed is the grayed out Photoshop options, and that only happened when a Windows update was pending. Now no problem.

    Like

  2. Thanks for this very helpful memo Tony. I agree that Photoshop CC 2019 is buggy, but the TKActions V6 panel seems to be fine on my Windows computer and laptop. My main problem was that I could not open an image in PS from Bridge. The quick fix that the Adobe Tech person had me try didn’t work so I had to let him take over control of my computer and do a rather long and complex fix. It was fascinating to watch! I wish Adobe didn’t find it necessary to do a major update every year; I’d rather they just fix bugs and leave us alone to work on our images!!

    I appreciate the effort you put in to provide support for the V6 Panel.

    All the best,

    Shirley Antes

    Sent from my iPad

    >

    Like

    1. Glad everything is working well for you, Shirley. I’m not sure that problem I mentioned in the blog applies to Bridge, though. I use Bridge too and for me it seems to be working fine. From what I’m reading, the issue I refer to is just when LR opens PS. Although there might be a Bridge issues too. I’ll keep reading the forums to see if anything pops up. It does seem that each new version of PS comes with a new set of bugs. It’s unfortunate, but part of the reality, I suppose, when working on suite as sprawling as Adobe. Adobe is obviously aware of this current problem and I’m sure they’ll get it fixed since it is somewhat major, I think.

      Like

    1. Yes, Mac seems to have gotten off easy this time, but that’s not always been the case. Most of the problems in the past have been Mac-related. I’ve actually coded several workarounds into the panel itself due to Mac bugs that Adobe hasn’t patched. I’m at least hopeful that this Windows bug will get fixed.

      Like

  3. Photoshop 2019 seems to freeze up on my DeskTop when I walk away from it for 10 or 15 minutes. I don’t think it has anything to do with Adobe or TK6. I do not have this problem on my Laptop? Other than that, everything in TK6 works well.

    Sure would like see some tutorials on B&W conversions?

    Like

  4. Tony

    Thanks for the update, I too have noticed PS 2019 is quite buggy.

    I use a loaded up Mac, not yet upgraded to Mojave OS.

    One thing that I have noticed a few times happens the using the Dodge/Burn actions in the V6 panel. An area that I paint will suddenly turn into a reddish or greenish tinted square. If I stop, turn the layer off and on again, it goes away. It may or may not happen when I resume painting. It doesn’t seem to affect the final image, but is annoying. I can send a screenshot if you’d like.

    Any info you may have would be great; I’ve not found anything on Adobe forums and I’m assuming it’s a bug in PS 2019.

    And also, thanks so much for creating the TK actions panel and the great support…I honestly don’t know what I would do without them and Sean Bagshaw’s superb tutorials.

    Brad ________________________________

    Like

    1. No one else has reported this, Brad, and I can’t replicate this on my MacBook air. I will say that by the time you start the painting process, Photoshop is completely controlling things. While the V6 panel can set up burning and dodging, it only creates the layers, brushes, and blend modes that make it easy. When you actually paint with the brush, the V6 isn’t doing anything at that point.

      The “square” you mention is really strange. Are you painting with a square brush? I doubt that you are, so it’s really odd that you get reddish or greenish tinted squares. This might be a good clue, but I just don’t know what it might mean. Also, the fact that you can correct this by turning the layer visibility of and back on is interesting. This suggests that Photoshop is having trouble creating the composite image after you paint. A few people have had a problem like this when their images have lots of layers. The on-screen composite doesn’t accurately reflect what the flattened image looks like. One way to test for this is to zoom into 100% magnification. This eliminates the compositing problem. So try zooming to 100% when you see this and see what happens. Are you painting on a image that already has lots of layers in the layer stack? If so, the compositing issue maybe be involved, but it’s hard to say. It’s normally associated with subtle brightness and contrast shifts, and not outright color tints. Also try flattening your image. Does that fix the problem? Photoshop doesn’t have to create a composite anymore once the image is flattened. If flattening fixes the problem, then creating an accurate composite might be an issue.

      If you can find a way to predictably replicate this, let me know. That’s really the key to understanding what’s going on and coming up with a solution.

      Like

      1. Oh, that’s actually good to hear, Joerg. That means there may be some hope then of figuring out what’s going on.

        Are you on Mac or Windows? Do you use a mouse or stylus for painting? There’s a lot of variables we’ll need to test for.

        If you (or anyone) can reliably reproduce this, please let me know. I’ve been trying repeatedly to get the tinted squares on my Mac this morning using different types of layers and brushes and blending modes, but so far everything is still working fine. No tinted squares where I paint. I’m using a mouse for painting, not a stylus.

        Joerg–Do you find that turning the layer visibility on and off fixes the problem also? What about flattening the image? Does that also fix it?

        Any additional information would be helpful. If you want to Skype and demo this via screen share, that would be great. Just use the “Contact me” link on the right and we’ll get it set up.

        Like

  5. Hi Tony,

    Ive found when I upgrade to the latest patch 20.0.1 photoshop it seems to break the TKActions panel masking capability, whilst the panels seem to load and remain visible, clicking on any of the masking functions does not execute any routines, and if I click on a Layer>Levels for instance i get the “Rapid Mask” required first message.

    If I roll back to version 20.0 with no other changes everything works again

    Any ideas on how to best resolve?

    Like

    1. It actually sounds like everything was working properly, Adrien. That “Rapid Mask” required first message is one I programmed into the panel myself. It means you did not create a Rapid Mask before trying to use the output options in the “Layer” button menu. The “Layer” button menu options look for and uses the Rapid Mask to create at the layer mask on the layer that’s created. If there is no Rapid Mask channel for it to find and use, you’ll get that message. So what you’re describing sounds entirely normal if you’ve not created a Rapid Mask first. Next time you get that message, create a Rapid Mask first using the buttons in the SOURCE, MASK, and MODIFY sections of the RapidMask2 panel. Then try the “Layer” output option you want. It should now work with no error message. Hope that helps, but let me know if you have additional questions.

      Like

      1. Hi Tony,

        Appreciate the quick response – unfortunately i think thats the problem – in that its not creating the rapid mask first, when i click on the source mask say a lights-1 or the composite button, which should automatically create the lights-1 as well, the button goes green but no mask is created, hence getting your error message as you mentioned when I then go to use the mask via the layer button – from my observation thats where the issue, the buttons dont seem to create the mask as intended, I just rolled back to 20.0 and the masking functionality has returned and behaves as normal – so it seems to be related to the 20.0.1 patch combination – hope this helps

        Like

      2. Adriene,

        Here’s the definitive test:

        1. Reboot your computer.
        2. Open Photoshop CC directly from its launch icon on your computer. Do NOT open PS CC by opening an image from Lightroom, Bridge, or ACR. Have Photoshop CC open BEFORE opening any image.
        3. Now open an image.
        4. Try using the panel.

        The panel should now work normally and will demonstrate that this an Adobe problem and not an issue with the panel.

        Tony

        Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s